PixelmonCraft Launcher

Try our PixelmonCraft Launcher, download the .jar file and place it inside a folder and double click the jar file to run! Download here.

Future of the community and updating to dark...

As you've probably all noticed, we have a Pixelmon Dark beta server running and people are already debating wether we should update our main pixelmon server to this version. Now if we would decide to eventually update it would mean that we could not revert the server back to an older version and could only support Pixelmon Dark and versions based from that version. If another group decides to make another version and it is not based on a previous mod version it could have problems updating properly. 

Pixelmon Dark Server

So, we found this new pixelmon mod called pixelmon dark. It's a cool mod that adds 100+ new Pokemon. We have decided to launch a beta server for the members. The server is using Pixelmon Dark Version 1.9, you must update to use this version. If you are using AT Launcher, you must install a new instance, and in the drop down box for version, select Pixelmon Dark 1.9. If you are not using AT Launcher, you must use the jar file and install it manually.

Here are a bunch of screenshots that me, falling_turtle, and hoeyz123 spent about 20 minutes taking: http://imgur.com/a/KfQde

Download on ATLauncher and select version PixelmonCraft-Dark-1.9

Pixelmon 5.1.2 server!

The new Pixelmon Server is opened! You can Download ATLauncher and join the Minecraft 1.10.2 with Pixelmon 5.1.2 server on IP: server.pixelmoncraft.com, PokeBank module for Pokemon Transfers has been added.
Click here to find out more!

Pages